summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-01-01 10:41:29 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-01-01 10:41:29 +0000
commit846a4af8932138bf4c35f8f24ca1fc3e4ad1c86a (patch)
tree43c29cfec54d8fb65c46dc854bd5755141633be1 /cpukit/itron/Makefile.am
parent2005-01-01 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-846a4af8932138bf4c35f8f24ca1fc3e4ad1c86a.tar.bz2
2005-01-01 Ralf Corsepius <ralf.corsepius@rtems.org>
* automake/compile.am, httpd/Makefile.am, itron/Makefile.am, libblock/Makefile.am, libcsupport/Makefile.am, libfs/Makefile.am, libmisc/Makefile.am, libnetworking/Makefile.am, librpc/Makefile.am, posix/Makefile.am, rtems/Makefile.am, sapi/Makefile.am, score/Makefile.am, wrapup/Makefile.am: Remove build-variant support.
Diffstat (limited to 'cpukit/itron/Makefile.am')
-rw-r--r--cpukit/itron/Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/cpukit/itron/Makefile.am b/cpukit/itron/Makefile.am
index cdcf7797e1..339eec0869 100644
--- a/cpukit/itron/Makefile.am
+++ b/cpukit/itron/Makefile.am
@@ -106,17 +106,11 @@ C_FILES = $(TASK_C_FILES) $(TASKSYNC_C_FILES) $(SEMAPHORE_C_FILES) \
AM_CPPFLAGS += -I$(top_builddir)
AM_CPPFLAGS += -D__RTEMS_INSIDE__
-EXTRA_LIBRARIES = libitron.a
-CLEANFILES += libitron.a
+noinst_LIBRARIES = libitron.a
libitron_a_SOURCES = $(C_FILES)
libitron_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
-EXTRA_LIBRARIES += libitron_g.a
-CLEANFILES += libitron_g.a
-libitron_g_a_SOURCES = $(libitron_a_SOURCES)
-libitron_g_a_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-
-all-local: $(PREINSTALL_FILES) libitron$(LIB_VARIANT).a
+all-local: $(PREINSTALL_FILES)
endif
UNUSED_C_FILES = src/cre_mbx.c src/del_mbx.c src/mboxtranslatereturncode.c \