summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 13:39:43 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-12 13:39:43 +0000
commit53a895846c4e76c6f5677e33bba0d16c5f4c5d68 (patch)
tree66edd92ef82792de037d63995eeaf447cf1c7b2a /cpukit/itron/Makefile.am
parent2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-53a895846c4e76c6f5677e33bba0d16c5f4c5d68.tar.bz2
2003-12-12 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Use mkdir_p. Remove dirs from PRE/TMPINSTALL_FILES.
Diffstat (limited to 'cpukit/itron/Makefile.am')
-rw-r--r--cpukit/itron/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/cpukit/itron/Makefile.am b/cpukit/itron/Makefile.am
index 4f44d64be3..b5c02cd179 100644
--- a/cpukit/itron/Makefile.am
+++ b/cpukit/itron/Makefile.am
@@ -126,9 +126,8 @@ EXTRA_DIST += $(C_FILES) $(UNUSED_C_FILES) src/TODO
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)
+ @$(mkdir_p) $(PROJECT_INCLUDE)
@: > $(PROJECT_INCLUDE)/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
if HAS_ITRON
$(PROJECT_INCLUDE)/itron.h: include/itron.h $(PROJECT_INCLUDE)/$(dirstamp)
@@ -136,9 +135,8 @@ $(PROJECT_INCLUDE)/itron.h: include/itron.h $(PROJECT_INCLUDE)/$(dirstamp)
PREINSTALL_FILES += $(PROJECT_INCLUDE)/itron.h
$(PROJECT_INCLUDE)/itronsys/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)/itronsys
+ @$(mkdir_p) $(PROJECT_INCLUDE)/itronsys
@: > $(PROJECT_INCLUDE)/itronsys/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/itronsys/$(dirstamp)
$(PROJECT_INCLUDE)/itronsys/eventflags.h: include/itronsys/eventflags.h $(PROJECT_INCLUDE)/itronsys/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/itronsys/eventflags.h
@@ -197,9 +195,8 @@ $(PROJECT_INCLUDE)/itronsys/vmempool.h: include/itronsys/vmempool.h $(PROJECT_IN
PREINSTALL_FILES += $(PROJECT_INCLUDE)/itronsys/vmempool.h
$(PROJECT_INCLUDE)/rtems/itron/$(dirstamp):
- @$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems/itron
+ @$(mkdir_p) $(PROJECT_INCLUDE)/rtems/itron
@: > $(PROJECT_INCLUDE)/rtems/itron/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/itron/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/itron/config.h: include/rtems/itron/config.h $(PROJECT_INCLUDE)/rtems/itron/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/itron/config.h