summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-04-01 10:59:51 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-04-01 10:59:51 +0000
commit30f66299a6610a217bd235e52ec3b2e4fda5d081 (patch)
treed2c3424041390e383bddae0245f539f41871adda /cpukit/itron/Makefile.am
parent2004-04-01 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-30f66299a6610a217bd235e52ec3b2e4fda5d081.tar.bz2
2004-04-01 Ralf Corsepius <ralf_corsepius@rtems.org>
* Makefile.am: Add backward/*.h headers. * itron/Makefile.am: Install itron.h to $(includedir)/rtems. * libcsupport/Makefile.am: Install RTEMS specific headers to $(includedir)/rtems. * libfs/Makefile.am: Install imfs.h and dosfs.h to $(includedir)/rtems.
Diffstat (limited to 'cpukit/itron/Makefile.am')
-rw-r--r--cpukit/itron/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/cpukit/itron/Makefile.am b/cpukit/itron/Makefile.am
index d4354b41d6..cdcf7797e1 100644
--- a/cpukit/itron/Makefile.am
+++ b/cpukit/itron/Makefile.am
@@ -11,7 +11,8 @@ CLEANFILES =
if HAS_ITRON
## include
-include_HEADERS = include/itron.h
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = include/itron.h
## itronsys
@@ -127,15 +128,15 @@ EXTRA_DIST += $(UNUSED_C_FILES) src/TODO
PREINSTALL_DIRS =
PREINSTALL_FILES =
-$(PROJECT_INCLUDE)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)
- @: > $(PROJECT_INCLUDE)/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/$(dirstamp)
-
if HAS_ITRON
-$(PROJECT_INCLUDE)/itron.h: include/itron.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/itron.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/itron.h
+$(PROJECT_INCLUDE)/rtems/$(dirstamp):
+ @$(mkdir_p) $(PROJECT_INCLUDE)/rtems
+ @: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+
+$(PROJECT_INCLUDE)/rtems/itron.h: include/itron.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/itron.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/itron.h
$(PROJECT_INCLUDE)/itronsys/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/itronsys