summaryrefslogtreecommitdiffstats
path: root/cpukit/itron/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-04-17 20:32:13 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-04-17 20:32:13 +0000
commit0ab34c90a20c03d84cad1b357da8fbc0258be6c0 (patch)
tree7d12c026af64c5f6c33746e8c5681a9a562b2054 /cpukit/itron/Makefile.am
parent2007-04-17 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-0ab34c90a20c03d84cad1b357da8fbc0258be6c0.tar.bz2
2007-04-17 Joel Sherrill <joel@OARcorp.com>
* itron/Makefile.am, itron/src/eventflags.c, itron/src/fmempool.c, itron/src/itronintr.c, itron/src/itrontime.c, itron/src/network.c, itron/src/port.c, itron/src/sysmgmt.c, itron/src/task.c, itron/src/vmempool.c, posix/Makefile.am, posix/src/pthread.c, rtems/src/taskinitusers.c, rtems/src/tasks.c, sapi/include/confdefs.h, sapi/src/io.c: Various modification to reduce executable size. Most were refactoring of files. Split ITRON API files. Implemented mechanism to avoid initialization task/thread loop being linked in when that style of task initialization was not being used. * itron/src/acp_por.c, itron/src/act_cyc.c, itron/src/cal_por.c, itron/src/chg_iXX.c, itron/src/clr_flg.c, itron/src/cre_flg.c, itron/src/cre_mpf.c, itron/src/cre_mpl.c, itron/src/cre_por.c, itron/src/def_alm.c, itron/src/def_cyc.c, itron/src/def_exc.c, itron/src/def_int.c, itron/src/def_svc.c, itron/src/del_flg.c, itron/src/del_mpf.c, itron/src/del_mpl.c, itron/src/del_por.c, itron/src/dis_int.c, itron/src/dly_tsk.c, itron/src/ena_int.c, itron/src/fwd_por.c, itron/src/get_blf.c, itron/src/get_blk.c, itron/src/get_tim.c, itron/src/get_ver.c, itron/src/itroninittasks.c, itron/src/loc_cpu.c, itron/src/nget_nod.c, itron/src/nget_ver.c, itron/src/nrea_dat.c, itron/src/nwri_dat.c, itron/src/pacp_por.c, itron/src/pcal_por.c, itron/src/pget_blf.c, itron/src/pget_blk.c, itron/src/pol_flg.c, itron/src/ref_alm.c, itron/src/ref_cfg.c, itron/src/ref_cyc.c, itron/src/ref_flg.c, itron/src/ref_iXX.c, itron/src/ref_mpf.c, itron/src/ref_mpl.c, itron/src/ref_por.c, itron/src/ref_sys.c, itron/src/rel_blf.c, itron/src/rel_blk.c, itron/src/ret_int.c, itron/src/ret_tmr.c, itron/src/ret_wup.c, itron/src/rpl_rdv.c, itron/src/set_flg.c, itron/src/set_tim.c, itron/src/tacp_por.c, itron/src/tcal_por.c, itron/src/tget_blf.c, itron/src/tget_blk.c, itron/src/twai_flg.c, itron/src/unl_cpu.c, itron/src/wai_flg.c, posix/src/pthreadinitthreads.c: New files.
Diffstat (limited to 'cpukit/itron/Makefile.am')
-rw-r--r--cpukit/itron/Makefile.am31
1 files changed, 22 insertions, 9 deletions
diff --git a/cpukit/itron/Makefile.am b/cpukit/itron/Makefile.am
index fc8d3541a5..4be5f740f1 100644
--- a/cpukit/itron/Makefile.am
+++ b/cpukit/itron/Makefile.am
@@ -56,7 +56,8 @@ include_rtems_itron_HEADERS += inline/rtems/itron/eventflags.inl \
TASK_C_FILES = src/task.c src/cre_tsk.c src/del_tsk.c src/sta_tsk.c \
src/ext_tsk.c src/exd_tsk.c src/ter_tsk.c src/dis_dsp.c src/ena_dsp.c \
- src/chg_pri.c src/rot_rdq.c src/rel_wai.c src/get_tid.c src/ref_tsk.c
+ src/chg_pri.c src/rot_rdq.c src/rel_wai.c src/get_tid.c src/ref_tsk.c \
+ src/itroninittasks.c
TASKSYNC_C_FILES = src/sus_tsk.c src/rsm_tsk.c src/frsm_tsk.c src/slp_tsk.c \
src/tslp_tsk.c src/wup_tsk.c src/can_wup.c
@@ -64,7 +65,9 @@ TASKSYNC_C_FILES = src/sus_tsk.c src/rsm_tsk.c src/frsm_tsk.c src/slp_tsk.c \
SEMAPHORE_C_FILES = src/itronsem.c src/cre_sem.c src/del_sem.c \
src/preq_sem.c src/ref_sem.c src/sig_sem.c src/twai_sem.c src/wai_sem.c
-EVENTFLAGS_C_FILES = src/eventflags.c
+EVENTFLAGS_C_FILES = src/eventflags.c src/cre_flg.c src/del_flg.c \
+ src/set_flg.c src/clr_flg.c src/wai_flg.c src/pol_flg.c \
+ src/twai_flg.c src/ref_flg.c
MAILBOX_C_FILES = src/mbox.c
@@ -72,19 +75,29 @@ MSGBUFFER_C_FILES = src/msgbuffer.c src/msgbuffertranslatereturncode.c \
src/cre_mbf.c src/del_mbf.c src/prcv_mbf.c src/psnd_mbf.c src/rcv_mbf.c \
src/ref_mbf.c src/snd_mbf.c src/trcv_mbf.c src/tsnd_mbf.c
-RENDEZVOUS_C_FILES = src/port.c
+RENDEZVOUS_C_FILES = src/port.c src/cre_por.c src/del_por.c src/cal_por.c \
+ src/pcal_por.c src/tcal_por.c src/acp_por.c src/pacp_por.c \
+ src/tacp_por.c src/fwd_por.c src/rpl_rdv.c src/ref_por.c
-INTERRUPT_C_FILES = src/itronintr.c
+INTERRUPT_C_FILES = src/itronintr.c src/def_int.c src/loc_cpu.c \
+ src/unl_cpu.c src/dis_int.c src/ena_int.c src/chg_iXX.c src/ref_iXX.c \
+ src/ret_int.c src/ret_wup.c
-VARIABLE_MEMORY_POOL_C_FILES = src/vmempool.c
+VARIABLE_MEMORY_POOL_C_FILES = src/vmempool.c src/cre_mpl.c src/del_mpl.c \
+ src/get_blk.c src/pget_blk.c src/tget_blk.c src/rel_blk.c src/ref_mpl.c
-FIXED_MEMORY_POOL_C_FILES = src/fmempool.c
+FIXED_MEMORY_POOL_C_FILES = src/fmempool.c src/cre_mpf.c src/del_mpf.c \
+ src/get_blf.c src/pget_blf.c src/tget_blf.c src/rel_blf.c src/ref_mpf.c
-TIME_C_FILES = src/itrontime.c
+TIME_C_FILES = src/itrontime.c src/set_tim.c src/get_tim.c src/dly_tsk.c \
+ src/def_cyc.c src/act_cyc.c src/ref_cyc.c src/def_alm.c src/ref_alm.c \
+ src/ret_tmr.c
-CONFIGURATION_C_FILES = src/sysmgmt.c
+CONFIGURATION_C_FILES = src/sysmgmt.c src/get_ver.c src/ref_sys.c \
+ src/ref_cfg.c src/def_svc.c src/def_exc.c
-NETWORK_C_FILES = src/network.c
+NETWORK_C_FILES = src/network.c src/nrea_dat.c src/nwri_dat.c \
+ src/nget_nod.c src/nget_ver.c
C_FILES = $(TASK_C_FILES) $(TASKSYNC_C_FILES) $(SEMAPHORE_C_FILES) \
$(EVENTFLAGS_C_FILES) $(MAILBOX_C_FILES) $(MSGBUFFER_C_FILES) \