summaryrefslogtreecommitdiffstats
path: root/cpukit/httpd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-02-03 06:21:42 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-02-03 06:21:42 +0000
commitb5d91addb9c6ba0513292e2f49694ea8b28d5cd5 (patch)
treecdf058ad1dabd28db62e3637e31f8e64d8e6096a /cpukit/httpd/Makefile.am
parent2004-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-b5d91addb9c6ba0513292e2f49694ea8b28d5cd5.tar.bz2
2004-02-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* libnetworking/rtems_webserver/Makefile.am: Add PREINSTALL_DIRS. * libnetworking/rtems_telnetd/Makefile.am: Add PREINSTALL_DIRS. * libnetworking/rtems_servers/Makefile.am: Add PREINSTALL_DIRS. * libnetworking/pppd/Makefile.am: Add PREINSTALL_DIRS.
Diffstat (limited to 'cpukit/httpd/Makefile.am')
-rw-r--r--cpukit/httpd/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/cpukit/httpd/Makefile.am b/cpukit/httpd/Makefile.am
index 85c24a4ac7..b43c29a1a3 100644
--- a/cpukit/httpd/Makefile.am
+++ b/cpukit/httpd/Makefile.am
@@ -39,19 +39,20 @@ all-local: $(PREINSTALL_FILES)
EXTRA_DIST = webcomp.c webpage.c
+PREINSTALL_DIRS =
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)
@: > $(PROJECT_INCLUDE)/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/$(dirstamp)
if HAS_NETWORKING
if HAS_POSIX
$(PROJECT_INCLUDE)/goahead/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/goahead
@: > $(PROJECT_INCLUDE)/goahead/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/goahead/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/goahead/$(dirstamp)
$(PROJECT_INCLUDE)/rtems_webserver.h: rtems_webserver.h $(PROJECT_INCLUDE)/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems_webserver.h
@@ -92,5 +93,6 @@ endif
endif
CLEANFILES += $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/automake/local.am