summaryrefslogtreecommitdiffstats
path: root/cpukit/ftpd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 17:52:38 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 17:52:38 +0000
commit38595dd11660b85b4b4137a6909ac2b320c89d44 (patch)
tree9d64abcfacd90407f27c1155c42d245c2c6a3e54 /cpukit/ftpd/Makefile.am
parent2005-02-08 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-38595dd11660b85b4b4137a6909ac2b320c89d44.tar.bz2
2005-02-08 Ralf Corsepius <ralf.corsepius@rtems.org>
* ftpd/Makefile.am: Split preinstallation rules in to separate preinstall.am-files. * ftpd/preinstall.am: New (Generated from corresponding Makefile.am).
Diffstat (limited to 'cpukit/ftpd/Makefile.am')
-rw-r--r--cpukit/ftpd/Makefile.am20
1 files changed, 5 insertions, 15 deletions
diff --git a/cpukit/ftpd/Makefile.am b/cpukit/ftpd/Makefile.am
index c76448b7e2..f43c2e9dcb 100644
--- a/cpukit/ftpd/Makefile.am
+++ b/cpukit/ftpd/Makefile.am
@@ -4,26 +4,16 @@
include $(top_srcdir)/automake/compile.am
+CLEANFILES =
+DISTCLEANFILES =
+
if HAS_NETWORKING
project_lib_LIBRARIES = libftpd.a
libftpd_a_SOURCES = ftpd.c ftpd.h
endif
-all-local: $(PREINSTALL_FILES)
-
-TMPINSTALL_FILES =
-
-$(PROJECT_LIB)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_LIB)
- @: > $(PROJECT_LIB)/$(dirstamp)
-TMPINSTALL_FILES += $(PROJECT_LIB)/$(dirstamp)
-
-if HAS_NETWORKING
-$(PROJECT_LIB)/libftpd.a: libftpd.a $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/libftpd.a
-TMPINSTALL_FILES += $(PROJECT_LIB)/libftpd.a
-endif
+all-local: $(PREINSTALL_FILES) $(TMPINSTALL_FILES)
-CLEANFILES = $(TMPINSTALL_FILES)
+include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am