summaryrefslogtreecommitdiffstats
path: root/cpukit/dev/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-07 13:47:39 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-20 10:30:06 +0100
commit41c5f1b7795d95179d1b501fc93b27abd6c19d27 (patch)
tree688c479d01b3ae9f5c6de24bc2ebcbee2068afc8 /cpukit/dev/Makefile.am
parentAdd RTEMS port of Linux I2C user-space API (diff)
downloadrtems-41c5f1b7795d95179d1b501fc93b27abd6c19d27.tar.bz2
Add I2C driver framework
This I2C driver framework has some major differences compared to libi2c. * It is compatible to the Linux I2C user-space API. * It uses generic IMFS nodes and thus reduces the levels of indirection. * The drivers don't have to mess around with minor numbers to get their state information. * No arbitrary bus controller model is assumed. The main task of an I2C bus controller driver is to process I2C messages. How this is done is private to the driver. * Scatter/gather operations are supported (I2C_M_NOSTART).
Diffstat (limited to 'cpukit/dev/Makefile.am')
-rw-r--r--cpukit/dev/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/cpukit/dev/Makefile.am b/cpukit/dev/Makefile.am
index 5f8fee6b71..c2913a6438 100644
--- a/cpukit/dev/Makefile.am
+++ b/cpukit/dev/Makefile.am
@@ -1,12 +1,23 @@
include $(top_srcdir)/automake/compile.am
+include $(top_srcdir)/automake/multilib.am
include_devdir = $(includedir)/dev
include_dev_HEADERS =
+include_dev_i2cdir = $(includedir)/dev/i2c
+include_dev_i2c_HEADERS =
+include_dev_i2c_HEADERS += include/dev/i2c/i2c.h
+
include_linuxdir = $(includedir)/linux
include_linux_HEADERS =
include_linux_HEADERS += include/linux/i2c.h
include_linux_HEADERS += include/linux/i2c-dev.h
+noinst_LIBRARIES = libdev.a
+
+libdev_a_SOURCES =
+libdev_a_SOURCES += i2c/i2c-bus.c
+libdev_a_SOURCES += i2c/i2c-dev.c
+
include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/local.am