summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-21 15:50:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-21 15:50:09 +0000
commitfd84982c0019205ea5e4c226f47dd62480cfd5e6 (patch)
treeb2915444f038f690cd390dfee72cc896319ba7b4 /cpukit/configure.ac
parent2007-12-21 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-fd84982c0019205ea5e4c226f47dd62480cfd5e6.tar.bz2
2007-12-21 Xi Yang <hiyangxi@gmail.com>
* configure.ac, score/include/rtems/score/coremutex.h, score/include/rtems/score/thread.h, score/inline/rtems/score/coremutex.inl, score/src/coremutexsurrender.c, score/src/threadinitialize.c: Add support for proper stacking of priority inheritance on mutexes as well as enforce proper order of release.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 3ec7a55281..04f2997d4a 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -224,6 +224,12 @@ RTEMS_CPUOPT([__RTEMS_DO_NOT_INLINE_THREAD_ENABLE_DISPATCH__],
[disable inlining _Thread_Enable_dispatch]
)
+RTEMS_CPUOPT([__STRICT_ORDER_MUTEX__],
+ [test x"${ENABLE_STRICT_ORDER_MUTEX}"=x"1"],
+ [1],
+ [disable strict order mutex]
+)
+
RTEMS_CPUOPT([__RTEMS_MAJOR__],
[true],
[$rtems_major],