summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-11-24 16:37:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-11-24 16:37:05 +0000
commitf4cc6c550f134122ef2519f88e25caafcad7f5dc (patch)
treead1a7859f95718354e5e600061eff555829641d4 /cpukit/configure.ac
parent2008-11-24 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-f4cc6c550f134122ef2519f88e25caafcad7f5dc.tar.bz2
Add AC_CHECK_FUNC's to check functions migrating into newlib.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 227657add0..96166f9c74 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -52,6 +52,12 @@ AC_CHECK_FUNCS([strdup strndup strncasecmp])
AC_CHECK_FUNCS([bcopy bcmp])
AC_CHECK_FUNCS([isascii fileno])
+# Newlib's posix directory
+AC_CHECK_FUNCS([opendir closedir readdir rewinddir scandir seekdir telldir isatty])
+
+# Newlib's unix/ directory
+AC_CHECK_FUNCS([ttyname getcwd])
+
## Check if the installed toolchain has these headers
AC_CHECK_HEADER([tar.h])