summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-21 15:57:22 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-21 15:57:22 +0000
commite2ba62d1ea181d8057c6c3f6ba2e9dc651f6aa3a (patch)
tree3ba6fcde8d360aa8552a7667159b04f67051c27b /cpukit/configure.ac
parent2007-12-21 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-e2ba62d1ea181d8057c6c3f6ba2e9dc651f6aa3a.tar.bz2
2007-12-21 Joel Sherrill <joel.sherrill@OARcorp.com>
* configure.ac, score/include/rtems/score/coremutex.h, score/inline/rtems/score/coremutex.inl: Add the ability to disable inlining coremutex seize. This reduces the code size and also improves the process of coverage analysis. * score/src/coremutexseizeintr.c: New file.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 04f2997d4a..f2faabf915 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -218,12 +218,21 @@ RTEMS_CPUOPT([__RTEMS_USE_TICKS_RATE_MONOTONIC_STATISTICS__],
[disable nanosecond granularity for period statistics]
)
+## This improves both the size and coverage analysis.
RTEMS_CPUOPT([__RTEMS_DO_NOT_INLINE_THREAD_ENABLE_DISPATCH__],
[test x"${RTEMS_DO_NOT_INLINE_THREAD_ENABLE_DISPATCH}" = x"1"],
[1],
[disable inlining _Thread_Enable_dispatch]
)
+## This improves both the size and coverage analysis.
+RTEMS_CPUOPT([__RTEMS_DO_NOT_INLINE_CORE_MUTEX_SEIZE__],
+ [test x"${RTEMS_DO_NOT_INLINE_CORE_MUTEX_SEIZE}" = x"1"],
+ [1],
+ [disable inlining _Thread_Enable_dispatch]
+)
+
+## This gives the same behavior as 4.8 and older
RTEMS_CPUOPT([__STRICT_ORDER_MUTEX__],
[test x"${ENABLE_STRICT_ORDER_MUTEX}"=x"1"],
[1],