summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2015-09-10 17:12:06 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2015-10-14 07:47:12 +0200
commitcff773f5802d0b5b4d007be3f6f4adbb04ce0d41 (patch)
treeafada47b1eb3d9ebbe755c8cd7eca6e3e9eec632 /cpukit/configure.ac
parentlibstdthreads: Import from FreeBSD (diff)
downloadrtems-cff773f5802d0b5b4d007be3f6f4adbb04ce0d41.tar.bz2
libstdthreads: Add C11 threads
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 14ce0f1a4c..01da86d3e4 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -141,6 +141,9 @@ AS_IF([test -n "$rtems_missing_header"],
AC_CHECK_HEADERS([semaphore.h])
AM_CONDITIONAL([HAVE_SEMAPHORE_H],[test x"$ac_cv_header_semaphore_h" = x"yes"])
+AC_CHECK_HEADERS([threads.h])
+AM_CONDITIONAL([HAVE_THREADS_H],[test x"$ac_cv_header_threads_h" = x"yes"])
+
## error out if libc doesn't provide stdint.h
AS_IF([test x"${ac_cv_header_stdint_h}" != xyes],
[AC_MSG_ERROR([Required header stdint.h not found])])
@@ -481,6 +484,7 @@ libmisc/Makefile
libi2c/Makefile
libmd/Makefile
libdl/Makefile
+libstdthreads/Makefile
zlib/Makefile
ftpd/Makefile
telnetd/Makefile