summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2006-11-15 14:17:57 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2006-11-15 14:17:57 +0000
commitbfe2fd37d037873ecbe33032e9ef41bdd2b8a76f (patch)
treea894217159d2ddd9150ed705929b5176590e1e70 /cpukit/configure.ac
parent2006-11-15 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-bfe2fd37d037873ecbe33032e9ef41bdd2b8a76f.tar.bz2
Remove RTEMS_AMPOLISH3.
Add checks for uint8_t, int8_t, uint16_t, int16_t, uint32_t, int32_t.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 51063a1b0c..a93492609f 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -97,6 +97,10 @@ AS_IF([test x"${ac_cv_header_stdint_h}" = xyes],
AS_IF([test x"${ac_cv_header_inttypes_h}" != xyes],
[AC_MSG_ERROR([Required header inttypes.h not found])])
+AC_CHECK_TYPES([ uint8_t, int8_t])
+AC_CHECK_TYPES([uint16_t, int16_t])
+AC_CHECK_TYPES([uint32_t, int32_t])
+
AS_IF([test x"${RTEMS_USE_NEWLIB}" = xyes],
[RTEMS_USES_TAR_H=yes],
[RTEMS_USES_TAR_H=$ac_cv_header_tar_h])
@@ -261,8 +265,6 @@ AM_CONDITIONAL([NEED_SYS_QUEUE_H],[test x"$NEED_SYS_QUEUE_H" = x"yes"])
AM_CONDITIONAL([LIBSHELL],[test x"$HAVE_ASSIGNABLE_STDIO" = x"yes"])
AM_CONDITIONAL([LIBSERDBG],[test x"$rtems_cv_cc_attribute_weak" = x"yes"])
-RTEMS_AMPOLISH3
-
AC_CONFIG_HEADER(config.h)
# Explicitly list all Makefiles here