summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2008-01-05 06:57:17 +0000
committerChris Johns <chrisj@rtems.org>2008-01-05 06:57:17 +0000
commita5de1ef5fc5b06d300e08dae2425d1bb88985645 (patch)
tree6e06dcd3f1c8fa3d93c25e7cc0d77c51b4a99700 /cpukit/configure.ac
parent2008-01-03 Till Straumann <strauman@slac.stanford.edu> (diff)
downloadrtems-a5de1ef5fc5b06d300e08dae2425d1bb88985645.tar.bz2
2008-01-05 Chris Johns <chrisj@rtems.org>
* configure.ac: Fix typo in the strict order mutex CPU OPTs test. * libmisc/shell/shell.c: Handle '#' comment characters correctly. * libblock/include/rtems/flashdisk.h: Add docmentation about the control fields. Add more control fields to handle the flash when full. * libblock/src/flashdisk.c: Fix the descriptor erase test so it detects a descriptor is erased. Add support for unavailable blocks the user can configure. Print the used list as a diag. Fix the bug when a page is detected as failed and present on more than one queue. Add a count to the queues so queue length can be used to manage compaction.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index c7b8545505..ab955de261 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -234,7 +234,7 @@ RTEMS_CPUOPT([__RTEMS_DO_NOT_INLINE_CORE_MUTEX_SEIZE__],
## This gives the same behavior as 4.8 and older
RTEMS_CPUOPT([__STRICT_ORDER_MUTEX__],
- [test x"${ENABLE_STRICT_ORDER_MUTEX}"= x"1"],
+ [test x"${ENABLE_STRICT_ORDER_MUTEX}" = x"1"],
[1],
[disable strict order mutex]
)