summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2011-11-28 10:11:10 +0100
committerDaniel Hellstrom <daniel@gaisler.com>2015-04-17 01:10:15 +0200
commita31845f7f9b4770cf9ddd8b6820641d2f4f4c1da (patch)
tree0d7f215ec45d7c4cf6f1293af72ece2fbde1ddc3 /cpukit/configure.ac
parentleon3,ngmp: simplify cpucounter initialization (diff)
downloadrtems-a31845f7f9b4770cf9ddd8b6820641d2f4f4c1da.tar.bz2
LIBPCI: added PCI layer to cpukit/libpci
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 00580824a0..d04ce87efd 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -410,6 +410,17 @@ esac
AM_CONDITIONAL(SHA,[test x"$HAVE_SHA" = x"yes"])
AC_MSG_RESULT([$HAVE_SHA])
+# Filter libpci to only build for architectures that have support for it
+AC_MSG_CHECKING([whether CPU supports libpci])
+case $RTEMS_CPU in
+ sparc)
+ HAVE_LIBPCI=yes ;;
+ *)
+ HAVE_LIBPCI=no ;;
+esac
+AM_CONDITIONAL(LIBPCI,[test x"$HAVE_LIBPCI" = x"yes"])
+AC_MSG_RESULT([$HAVE_LIBPCI])
+
RTEMS_AMPOLISH3
# Explicitly list all Makefiles here
@@ -448,6 +459,7 @@ libgnat/Makefile
libcrypt/Makefile
libcsupport/Makefile
libnetworking/Makefile
+libpci/Makefile
librpc/Makefile
libmisc/Makefile
libi2c/Makefile