summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-11-25 15:13:36 +1100
committerChris Johns <chrisj@rtems.org>2016-11-29 08:50:40 +1100
commita0d4e9933c57693f99203da358bb8aaa8a5d50d9 (patch)
treed17a98faf93185d2baa18fba6ee97b0e2916b2e4 /cpukit/configure.ac
parentarm/zynq: Wait for the UART TX FIFO to empty on reset. (diff)
downloadrtems-a0d4e9933c57693f99203da358bb8aaa8a5d50d9.tar.bz2
cpukit: Add libdebugger, a remote debugger agent for GDB.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 5a6c2e66bf..3ebf5960e7 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -396,6 +396,17 @@ esac
AM_CONDITIONAL(LIBDL,[test x"$HAVE_LIBDL" = x"yes"])
AC_MSG_RESULT([$HAVE_LIBDL])
+# Filter debugger to only build for architectures that have a target backend
+AC_MSG_CHECKING([whether CPU supports libdebugger])
+case $RTEMS_CPU in
+ arm | i386)
+ HAVE_LIBDEBUGGER=yes ;;
+ *)
+ HAVE_LIBDEBUGGER=no ;;
+esac
+AM_CONDITIONAL(LIBDEBUGGER,[test x"$HAVE_LIBDEBUGGER" = x"yes"])
+AC_MSG_RESULT([$HAVE_LIBDEBUGGER])
+
AC_MSG_CHECKING([whether CPU supports SHA])
case $RTEMS_CPU in
m32c)
@@ -474,6 +485,7 @@ libi2c/Makefile
libmd/Makefile
libdl/Makefile
libstdthreads/Makefile
+libdebugger/Makefile
zlib/Makefile
ftpd/Makefile
telnetd/Makefile