summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2007-02-07 03:36:52 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2007-02-07 03:36:52 +0000
commit9a673dbaa8e1c59d3ad013a4092ca33fae7b6823 (patch)
tree399609ec6165d4bcdfbfa99966ba75891bbfac20 /cpukit/configure.ac
parent2007-02-06 Till Straumann <strauman@slac.stanford.edu> (diff)
downloadrtems-9a673dbaa8e1c59d3ad013a4092ca33fae7b6823.tar.bz2
2007-02-07 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Check fo intmax_t, uintptr_t, intptr_t, pthread.h, pthread_rwlock_t, pthread_barrier_t, pthread_spinlock_t.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 0e14f05521..94dc914bc2 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -2,7 +2,7 @@
##
## $Id$
-AC_PREREQ(2.60)
+AC_PREREQ(2.61)
AC_INIT([rtems-cpukit],[_RTEMS_VERSION],[http://www.rtems.org/bugzilla])
AC_CONFIG_SRCDIR([score])
RTEMS_TOP([..],[])
@@ -72,7 +72,17 @@ AC_CHECK_TYPES([ uint8_t, int8_t])
AC_CHECK_TYPES([uint16_t, int16_t])
AC_CHECK_TYPES([uint32_t, int32_t])
AC_CHECK_TYPES([uint64_t, int64_t])
-AC_CHECK_TYPES([uintmax_t])
+AC_CHECK_TYPES([uintmax_t, intmax_t])
+AC_CHECK_TYPES([uintptr_t, intptr_t])
+
+# These are conditionally defined by the toolchain
+# FIXME: we should either conditionally compile those parts in
+# RTEMS depending on them, or abort - For now, simply check.
+AC_CHECK_HEADER([pthread.h],[
+ AC_CHECK_TYPES([pthread_rwlock_t])
+ AC_CHECK_TYPES([pthread_barrier_t])
+ AC_CHECK_TYPES([pthread_spinlock_t])
+])
RTEMS_CHECK_MULTIPROCESSING
RTEMS_CHECK_POSIX_API