summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-08-10 13:07:29 +1000
committerChris Johns <chrisj@rtems.org>2016-08-11 17:20:10 +1000
commit9a4eca584321408ecac7b67a562d9c37be719d6a (patch)
treec8f0b5e9e4a1840ddf87d4ad6313613c1f4cf128 /cpukit/configure.ac
parentposix: nanosleep: adjust elapsed time calculation (diff)
downloadrtems-9a4eca584321408ecac7b67a562d9c37be719d6a.tar.bz2
build-system: Always enable C++ if the compiler is present.
We always build a C++ compiler and building with C++ does not effect RTEMS or the runtime. This patch always enabled the support. There is no need to manually enable it any more. You can disable C++ with '--disable-cxx'. If an architecture does not have a C++ compiler support is automatically disabled.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 054e60e62b..136630bd7e 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -13,6 +13,7 @@ AM_MAINTAINER_MODE
RTEMS_ENABLE_MULTILIB
RTEMS_ENABLE_MULTIPROCESSING
RTEMS_ENABLE_POSIX
+RTEMS_ENABLE_CXX
RTEMS_ENABLE_RTEMS_DEBUG
RTEMS_ENABLE_NETWORKING
RTEMS_ENABLE_PARAVIRT
@@ -31,9 +32,10 @@ else
fi
RTEMS_PROG_CC_FOR_TARGET
-RTEMS_PROG_CCAS
-RTEMS_CANONICALIZE_TOOLS
+RTEMS_PROG_CXX_FOR_TARGET
AM_PROG_CC_C_O
+RTEMS_CANONICALIZE_TOOLS
+RTEMS_PROG_CCAS
AC_PROG_RANLIB
RTEMS_CHECK_NEWLIB