summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-08-22 14:00:56 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-08-22 14:00:56 +0000
commit97b4bc1bbc0258d0a0d40498140563483ecde60e (patch)
treea9986a5163a187698896642ff0815c87586a562b /cpukit/configure.ac
parent2002-08-21 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-97b4bc1bbc0258d0a0d40498140563483ecde60e.tar.bz2
2002-08-22 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* aclocal/prog-gnat.m4: New. * configure.ac: Add ada subdir handling.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 70e5dc3508..0422376179 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -83,6 +83,13 @@ AC_MSG_RESULT([$LIBRPC])
])
AM_CONDITIONAL(LIBRPC,[test "$LIBRPC" = "yes"])
+AC_ARG_ENABLE([ada],[enable ada support])
+AS_IF([test x"$enable_ada" = x"yes"],[
+ AS_IF([test -d ${srcdir}/ada],[
+ AC_CONFIG_SUBDIRS([ada])
+ ])
+])
+
RTEMS_DEFINE_POSIX_API
RTEMS_DEFINE_ITRON_API
RTEMS_DEFINE_MULTIPROCESSING