summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-10-29 16:40:03 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-10-29 16:40:03 +0000
commit965c49b290bc387b2917a3e1bc2168fc27893785 (patch)
treece69456aea97eb4de477415eef96a1e3c8cc468b /cpukit/configure.ac
parent2002-10-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-965c49b290bc387b2917a3e1bc2168fc27893785.tar.bz2
2002-10-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* aclocal/multilib.m4: Remove RTEMS_ENABLE_MULTILIB_MASTER.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 8a5ea2b02e..9dd7090ad2 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -83,7 +83,14 @@ AC_MSG_RESULT([$LIBRPC])
])
AM_CONDITIONAL(LIBRPC,[test "$LIBRPC" = "yes"])
-AC_ARG_ENABLE([ada],[enable ada support])
+AC_ARG_ENABLE([ada],
+[AC_HELP_STRING([--enable-ada],[enable ada support])],
+[case "${enable_ada}" in
+ yes) ;;
+ no) ;;
+ *) AC_MSG_ERROR([bad value ${enable_ada} for --enable-ada]) ;;
+esac],[enable_ada=no])
+
AS_IF([test x"$enable_ada" = x"yes"],[
AS_IF([test x"$HAS_POSIX_API" = x"yes"],[
AC_CONFIG_SUBDIRS([ada])