summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-12-02 08:33:35 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-12-02 09:24:51 +0100
commit927a0a1f990c19a3e7295bb001896b3f3c75a77e (patch)
treeb4c1cdb1a406b700a17b80e235613c9ced8c0cd9 /cpukit/configure.ac
parentpstmtests_plan.csv: Update to reflect psxtmcond 09 and 10 exit (diff)
downloadrtems-927a0a1f990c19a3e7295bb001896b3f3c75a77e.tar.bz2
posix: Use cleanup contexts on the stack
Provide support for latest Newlib <pthread.h> change. The cleanup contexts are stored on the thread stack. This is conformant with the POSIX requirements for the pthread_cleanup_push() and pthread_cleanup_pop() statement pair. Passing an invalid pointer as the routine to pthread_cleanup_push() is now a usage error and the behaviour is undefined.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index e111fdd0fc..38d2dd9eba 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -140,6 +140,7 @@ AC_CHECK_HEADER([pthread.h],[
AC_CHECK_TYPES([pthread_rwlock_t])
AC_CHECK_TYPES([pthread_barrier_t])
AC_CHECK_TYPES([pthread_spinlock_t])
+ AC_CHECK_TYPES([struct _pthread_cleanup_context],[],[],[#include <pthread.h>])
])
AC_CHECK_HEADER([signal.h],[