summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-07-26 09:34:32 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2013-07-26 11:55:48 +0200
commit91404ded256023f89c1065ae92ef3ba181bfd635 (patch)
treef28a5e2dda3dc7b5a78e0ca548b2a08243ddf4c8 /cpukit/configure.ac
parentbsps: Include missing <rtems/score/heapimpl.h> (diff)
downloadrtems-91404ded256023f89c1065ae92ef3ba181bfd635.tar.bz2
libmisc: Provide libutf8proc conditionally
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index f897eced5c..da02f24166 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -280,6 +280,8 @@ AC_CHECK_SIZEOF([off_t])
# FIXME: We should get rid of this. It's a cludge.
AC_CHECK_SIZEOF([time_t])
+AC_CHECK_SIZEOF([size_t])
+
# FIXME: Mandatory in SUSv4, optional in SUSv3.
# Not implemented in GCC/newlib, so far.
AC_CHECK_DECLS([WORD_BIT],,,[#include <limits.h>])
@@ -317,6 +319,8 @@ AM_CONDITIONAL([LIBSERDBG],[test x"$rtems_cv_cc_attribute_weak" = x"yes"])
AM_CONDITIONAL([LIBGNAT],[test x"$rtems_cv_HAS_POSIX_API" = x"yes" \
&& test x"$enable_ada" = x"yes"])
+AM_CONDITIONAL([LIBUTF8PROC],[test $ac_cv_sizeof_size_t -gt 2])
+
AM_CONDITIONAL([LIBDOSFS],[dnl
test x"$ac_cv_type_uint8_t" = xyes \
&& test x"$ac_cv_type_uint16_t" = xyes])