summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-12-30 05:18:42 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-12-30 05:18:42 +0000
commit85c429b5234b8a09a18ea56cd4031332ba3ecf08 (patch)
treec9d64bb838b334924d81ab77525aa023048bc1f6 /cpukit/configure.ac
parentspi-sd-card.c, spi-sd-card.h: removed high-level driver IF, added generic blo... (diff)
downloadrtems-85c429b5234b8a09a18ea56cd4031332ba3ecf08.tar.bz2
2008-12-29 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Require <errno.h>. Cleanup comments. Remove check for <sys/errno.h>.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 11751ff74c..e8275e449d 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -73,14 +73,18 @@ AC_CHECK_HEADER([tar.h])
AC_CHECK_HEADER([sys/errno.h],[],
[AC_MSG_ERROR([Missing required header sys/errno.h])])
-## if libc provides stdint.h, use it.
+## error out if libc doesn't provide stdint.h
AS_IF([test x"${ac_cv_header_stdint_h}" != xyes],
[AC_MSG_ERROR([Required header stdint.h not found])])
-## error out if libc doesn't at least provide inttypes.h
+## error out if libc doesn't provide inttypes.h
AS_IF([test x"${ac_cv_header_inttypes_h}" != xyes],
[AC_MSG_ERROR([Required header inttypes.h not found])])
+## error out if libc doesn't provide errno.h
+AS_IF([test x"${ac_cv_header_errno_h}" != xyes],
+[AC_MSG_ERROR([Required header errno.h not found])])
+
AC_HEADER_STDBOOL
AS_IF([test x"${ac_cv_header_stdbool_h}" != xyes],
[AC_MSG_ERROR([No sufficient stdbool.h found])])