summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-07-08 12:24:02 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-07-08 12:24:02 +0000
commit85956f9b923a2d511a6bf83c7aca4d74a1c1c170 (patch)
tree6646c91ab82dff8f2be5f25c6b0ce976938b20a5 /cpukit/configure.ac
parent2003-07-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-85956f9b923a2d511a6bf83c7aca4d74a1c1c170.tar.bz2
2003-07-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Merge-in libnetworking/configure.ac. Remove "rtems-" from RTEMS_VERSION. Add AC_CHECK_FUNCS([strsep strcasecmp snprintf]). * Makefile.am: Add libmisc to SUBDIRS.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index ad9b09ad53..972e96a22c 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -49,7 +49,7 @@ AM_CONDITIONAL(INLINE,test x"$INLINEdir" = x"inline" )
AM_CONDITIONAL(MACROS,test x"$INLINEdir" = x"macros" )
AM_CONDITIONAL(HAS_MP,test x"$HAS_MP" = x"yes" )
-AC_DEFINE(RTEMS_VERSION,["rtems-][_RTEMS_VERSION]["],[RTEMS version string])
+AC_DEFINE(RTEMS_VERSION,["][_RTEMS_VERSION]["],[RTEMS version string])
AM_CONDITIONAL(HAS_POSIX,test x"$HAS_POSIX_API" = x"yes")
AM_CONDITIONAL(HAS_ITRON,test x"$HAS_ITRON_API" = x"yes")
@@ -67,8 +67,8 @@ AM_CONDITIONAL([LIBSCORECPU],
[test -f "${srcdir}/score/cpu/${RTEMS_CPU}/cpu.c"])
AC_CONFIG_SUBDIRS([libcsupport])
+
AS_IF([test x"$HAS_NETWORKING" = x"yes"],[
- AC_CONFIG_SUBDIRS(libnetworking)
## FIXME: Should better use a feature-based test
AC_MSG_CHECKING([whether CPU supports librpc])
case "$RTEMS_CPU" in
@@ -109,6 +109,7 @@ AS_IF([test x"${enable_unixlib}" = x"yes"],
[to indicate RTEMS using RTEMS's unixlib])]
)
+AC_CHECK_FUNCS([strsep strcasecmp snprintf])
AM_CONFIG_HEADER([score/include/rtems/score/cpuopts-tmp.h],[
echo "/* target cpu dependent options file */" >$tmp/config.h
@@ -188,6 +189,11 @@ libfs/src/Makefile
libfs/src/imfs/Makefile
libfs/src/dosfs/Makefile])
+AC_CONFIG_FILES([libnetworking/Makefile
+libnetworking/lib/Makefile
+libnetworking/libc/Makefile
+libnetworking/wrapup/Makefile])
+
AC_CONFIG_FILES([ada/Makefile])
AC_CONFIG_FILES([libmisc/Makefile