summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2013-12-09 14:22:33 -0600
committerJoel Sherrill <joel.sherrill@oarcorp.com>2013-12-13 08:35:52 -0600
commit801a1fc6b2beab0c53c8d27fd32022c10f095510 (patch)
tree3f184a0c17bfce898816829107b2df5959545f55 /cpukit/configure.ac
parentpsxtests/configure.ac: Probe for SMP affinity methods (diff)
downloadrtems-801a1fc6b2beab0c53c8d27fd32022c10f095510.tar.bz2
cpukit/configure.ac: Probe for SMP affinity methods
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 38d2dd9eba..211f52771a 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -97,6 +97,14 @@ RTEMS_CHECK_FUNC([pthread_attr_setguardsize],[#include <pthread.h>])
RTEMS_CHECK_FUNC([pthread_attr_setstack],[#include <pthread.h>])
RTEMS_CHECK_FUNC([pthread_attr_getstack],[#include <pthread.h>])
+# These are SMP related and were added to newlib by RTEMS.
+RTEMS_CHECK_FUNC([pthread_attr_setaffinity_np],[#include <pthread.h>])
+RTEMS_CHECK_FUNC([pthread_attr_getaffinity_np],[#include <pthread.h>])
+RTEMS_CHECK_FUNC([pthread_setaffinity_np],[#include <pthread.h>])
+RTEMS_CHECK_FUNC([pthread_getaffinity_np],[#include <pthread.h>])
+RTEMS_CHECK_FUNC([pthread_getattr_np],[#include <pthread.h>])
+AC_CHECK_HEADERS([cpuset.h])
+
# Mandated by POSIX, not declared in some versions of newlib.
AC_CHECK_DECLS([getrusage],,,[#include sys/resource.h])