summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2011-10-24 13:08:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2011-10-24 13:08:05 +0000
commit74bfa2e4925d1c8d237b640c8a347baab5683e28 (patch)
tree7419455d8b884af25fc07aa570200c0f5c63ae2e /cpukit/configure.ac
parent2011-10-24 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-74bfa2e4925d1c8d237b640c8a347baab5683e28.tar.bz2
2011-10-24 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Check for decls of utime and utimes.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index da7e2b1384..d0dd326229 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -298,6 +298,15 @@ AC_CHECK_DECLS([sbrk],,,[#include <unistd.h>])
## Check if libc provides BSD's strlcpy/strlcat
AC_CHECK_FUNCS(strlcpy strlcat)
+## Check if libc provides decl of utime
+## FIXME: utime has been deprecated in SUSv4.
+## and is likely to be removed in future versions.
+## FIXME (BUG in newlib): SUSv4 saids including <utime.h> should be sufficient.
+AC_CHECK_DECLS([utime],,,[#include <sys/types.h>
+#include <utime.h>])
+## Check if libc provides decl of utimes
+AC_CHECK_DECLS([utimes],,,[#include <sys/time.h>])
+
# ... far too many conditionals ...
AM_CONDITIONAL(LIBRPC,[test x"$rtems_cv_HAS_NETWORKING" = x"yes"])
AM_CONDITIONAL(NEWLIB,test x"$RTEMS_USE_NEWLIB" = x"yes")