summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2009-10-30 05:45:51 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2009-10-30 05:45:51 +0000
commit72e975e60684e4f567f8cacd1bb304b8c2a7241b (patch)
tree47593f3d2e1353c63a37209fea161d6effff1875 /cpukit/configure.ac
parentNew. (diff)
downloadrtems-72e975e60684e4f567f8cacd1bb304b8c2a7241b.tar.bz2
2009-10-30 Ralf Corsépius <ralf.corsepiu@rtems.org>
* aclocal/gcc-sanity.m4: New. * configure.ac: Add RTEMS_CHECK_GCC_SANITY.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac22
1 files changed, 2 insertions, 20 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 12b91d0cba..994f770844 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -87,26 +87,8 @@ AC_CHECK_TYPES([uint64_t, int64_t])
AC_CHECK_TYPES([uintmax_t, intmax_t])
AC_CHECK_TYPES([uintptr_t, intptr_t])
-AC_CACHE_CHECK([if PRIxPTR works],
-[rtems_cv_PRIxPTR],[
- AS_IF([test x"$GCC" = xyes],[
- save_CFLAGS=$CFLAGS
- CFLAGS=-Werror])
-
- AC_COMPILE_IFELSE([
- AC_LANG_PROGRAM([
- #include <inttypes.h>
- #include <stdio.h>
- ],[
- void *ptr;
- printf("%" PRIxPTR "\n", (intptr_t) ptr);
- ])],
- [rtems_cv_PRIxPTR=yes],
- [rtems_cv_PRIxPTR=no])
-
- AS_IF([test x"$GCC" = xyes],[
- CFLAGS=$save_CFLAGS])
-])
+# Some toolchain sanity checks and diagnostics
+RTEMS_CHECK_GCC_SANITY
# These are conditionally defined by the toolchain
# FIXME: we should either conditionally compile those parts in