summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-12-03 20:34:24 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-12-03 20:34:24 +0000
commit57e278dab9aadae2d9de8c6d2d880d7a0363a156 (patch)
tree336ec95ed94b67ae454b8478f1e7e28b61e3463e /cpukit/configure.ac
parentTypo. (diff)
downloadrtems-57e278dab9aadae2d9de8c6d2d880d7a0363a156.tar.bz2
2010-12-03 Joel Sherrill <joel.sherrill@oarcorp.com>
* configure.ac, posix/src/signal_2.c: sighandler_t is defined conditionally in some versions of newlib and unconditionally in others. Make sure we always compile.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 0e2b65afe2..63413bdb82 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -134,7 +134,11 @@ AC_CHECK_HEADER([pthread.h],[
AC_CHECK_TYPES([pthread_spinlock_t])
])
-RTEMS_CHECK_MULTIPROCESSING
+AC_CHECK_HEADER([signal.h],[
+ AC_CHECK_TYPES([sighandler_t])
+])
+
+ RTEMS_CHECK_MULTIPROCESSING
RTEMS_CHECK_POSIX_API
RTEMS_CHECK_NETWORKING