summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-11-27 20:51:18 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-11-27 20:51:18 +0000
commit5603b5a6e96e9e8f578e8a402654a0dd67ab0bbf (patch)
treee5b0984c94e02ca57c1d5d27247bf32d2a7c52df /cpukit/configure.ac
parent2007-11-27 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-5603b5a6e96e9e8f578e8a402654a0dd67ab0bbf.tar.bz2
2007-11-27 Joel Sherrill <joel.sherrill@OARcorp.com>
* configure.ac, score/inline/rtems/score/thread.inl, score/src/threaddispatch.c: Add ability for user to disable inlining of _Thread_Enable_dispatch. This can save code space but more importantly it means the binary generated does not have code inlined that is difficult to test and very seldom executed.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 5e87f4a494..91b6804e26 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -224,6 +224,12 @@ RTEMS_CPUOPT([__RTEMS_USE_TICKS_RATE_MONOTONIC_STATISTICS__],
[disable nanosecond granularity for period statistics]
)
+RTEMS_CPUOPT([__RTEMS_DO_NOT_INLINE_THREAD_ENABLE_DISPATCH__],
+ [test x"${RTEMS_DO_NOT_INLINE_THREAD_ENABLE_DISPATCH}" = x"1"],
+ [1],
+ [disable inlining _Thread_Enable_dispatch]
+)
+
RTEMS_CPUOPT([__RTEMS_MAJOR__],
[true],
[$rtems_major],