summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-12-17 06:39:14 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-12-17 06:39:14 +0000
commit52a634e9980d67cb4775580cdb4e388b1042f5fb (patch)
tree45e61f033f7fc458a06831fdcb3697a36422a5ef /cpukit/configure.ac
parent2008-12-17 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-52a634e9980d67cb4775580cdb4e388b1042f5fb.tar.bz2
2008-12-17 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Require stdint.h.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac10
1 files changed, 2 insertions, 8 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 4288faa32a..11751ff74c 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -74,9 +74,8 @@ AC_CHECK_HEADER([sys/errno.h],[],
[AC_MSG_ERROR([Missing required header sys/errno.h])])
## if libc provides stdint.h, use it.
-AS_IF([test x"${ac_cv_header_stdint_h}" = xyes],
-[RTEMS_USES_STDINT_H=yes],
-[RTEMS_USES_STDINT_H=no])
+AS_IF([test x"${ac_cv_header_stdint_h}" != xyes],
+[AC_MSG_ERROR([Required header stdint.h not found])])
## error out if libc doesn't at least provide inttypes.h
AS_IF([test x"${ac_cv_header_inttypes_h}" != xyes],
@@ -195,11 +194,6 @@ RTEMS_CPUOPT([RTEMS_UNIXLIB],
[1],
[to indicate RTEMS using RTEMS's unixlib])
-RTEMS_CPUOPT([RTEMS_USES_STDINT_H],
- [test x"${RTEMS_USES_STDINT_H}" = x"yes"],
- [1],
- [if RTEMS uses stdint.h])
-
RTEMS_CPUOPT([RTEMS_USES_TAR_H],
[test x"${RTEMS_USES_TAR_H}" = x"yes"],
[1],