summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorWeiY <wei.a.yang@gmail.com>2013-04-24 00:34:17 +0800
committerGedare Bloom <gedare@rtems.org>2013-05-01 10:28:48 -0400
commit502693f50ec60c0e03ac9c245d7b5e0e06272679 (patch)
treed6e1c102f0bb8c946fdb4403b559c768e5ebf25b /cpukit/configure.ac
parentUsing the generic atomic ops to implement UP mode atomic for all architecture... (diff)
downloadrtems-502693f50ec60c0e03ac9c245d7b5e0e06272679.tar.bz2
Clear the atomic conditional compilation.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index f897eced5c..d82d30f039 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -149,7 +149,6 @@ RTEMS_CHECK_MULTIPROCESSING
RTEMS_CHECK_POSIX_API
RTEMS_CHECK_NETWORKING
RTEMS_CHECK_SMP
-RTEMS_CHECK_ATOMIC
rtems_major=`echo _RTEMS_VERSION | sed "s/\..*//"`
rtems_minor=`echo _RTEMS_VERSION | sed "s/[[0-9]][[0-9]]*\.//;s/\..*//"`
@@ -187,11 +186,6 @@ RTEMS_CPUOPT([RTEMS_NETWORKING],
[1],
[if networking is enabled])
-RTEMS_CPUOPT([RTEMS_ATOMIC],
- [test x"$rtems_cv_ATOMIC" = xyes],
- [1],
- [if cpu supports atomic operations])
-
RTEMS_CPUOPT([RTEMS_VERSION],
[true],
["]_RTEMS_VERSION["],
@@ -310,7 +304,6 @@ AM_CONDITIONAL(HAS_SMP,[test "$RTEMS_HAS_SMP" = "yes"])
AM_CONDITIONAL(HAS_PTHREADS,test x"$rtems_cv_HAS_POSIX_API" = x"yes")
AM_CONDITIONAL(LIBNETWORKING,test x"$rtems_cv_HAS_NETWORKING" = x"yes")
-AM_CONDITIONAL([ATOMIC],[test x"$rtems_cv_ATOMIC" = x"yes"])
AM_CONDITIONAL([LIBSHELL],[test x"$HAVE_ASSIGNABLE_STDIO" = x"yes"])
AM_CONDITIONAL([LIBSERDBG],[test x"$rtems_cv_cc_attribute_weak" = x"yes"])