summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2015-04-13 10:32:50 +0200
committerDaniel Hellstrom <daniel@gaisler.com>2015-04-17 01:10:28 +0200
commit4f0906080d2b90388f2154d38d7389bc34496ef4 (patch)
tree2b1a8aeb190d44fb1cbf9fe55a7c74e44437be15 /cpukit/configure.ac
parentsparc bsps: updated license to rtems.org (diff)
downloadrtems-4f0906080d2b90388f2154d38d7389bc34496ef4.tar.bz2
DRVMGR: only build on SPARC platform
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 69319ad65f..2b432f6437 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -427,6 +427,18 @@ esac
AM_CONDITIONAL(LIBPCI,[test x"$HAVE_LIBPCI" = x"yes"])
AC_MSG_RESULT([$HAVE_LIBPCI])
+# Filter libdrvmgr to only build for architectures that have support for it
+AC_MSG_CHECKING([whether CPU supports libdrvmgr])
+case $RTEMS_CPU in
+ sparc)
+ HAVE_LIBDRVMGR=yes ;;
+ *)
+ HAVE_LIBDRVMGR=no ;;
+esac
+AM_CONDITIONAL(LIBDRVMGR,[test x"$HAVE_LIBDRVMGR" = x"yes"])
+AC_MSG_RESULT([$HAVE_LIBDRVMGR])
+
+
RTEMS_AMPOLISH3
# Explicitly list all Makefiles here