summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2006-11-18 02:43:10 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2006-11-18 02:43:10 +0000
commit461d93f4a79c15659013246d45053de30d4e39fd (patch)
tree58e02477574a9b73174a9bc8dd9321b18111a171 /cpukit/configure.ac
parent2006-11-18 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-461d93f4a79c15659013246d45053de30d4e39fd.tar.bz2
2006-11-18 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Remove $LIBRPC.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 1ade31c596..4ab8df9162 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -43,16 +43,6 @@ RTEMS_CHECK_POSIX_API
RTEMS_CHECK_ITRON_API
RTEMS_CHECK_NETWORKING
-AS_IF([test x"$HAS_NETWORKING" = x"yes"],[
-## FIXME: Should better use a feature-based test
-AC_MSG_CHECKING([whether CPU supports librpc])
- case "$RTEMS_CPU" in
- c4x ) LIBRPC=no;;
- * ) LIBRPC=yes;;
- esac
-AC_MSG_RESULT([$LIBRPC])
-])
-
AC_ARG_ENABLE([deprecated],
[AS_HELP_STRING(--enable-deprecated,allow using deprecated files)],
[case "${enable_deprecated}" in
@@ -257,7 +247,7 @@ AC_CHECK_FUNCS(strlcpy strlcat)
# ... far too many conditionals ...
-AM_CONDITIONAL(LIBRPC,[test "$LIBRPC" = "yes"])
+AM_CONDITIONAL(LIBRPC,[test "$HAS_NETWORKING" = "yes"])
AM_CONDITIONAL(UNIX,[test x"${RTEMS_CPU}" = x"unix"])
AM_CONDITIONAL(NEWLIB,test x"$RTEMS_USE_NEWLIB" = x"yes")