summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-11-08 19:14:27 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-11-08 19:14:27 +0000
commit28caa1d11bc3b9b2828c58571ec71cb847b9bacd (patch)
treeded46a76785f9443c5849feed77c952cdf864aec /cpukit/configure.ac
parent2005-11-08 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-28caa1d11bc3b9b2828c58571ec71cb847b9bacd.tar.bz2
2005-11-08 Ralf Corsepius <ralf.corsepius@rtems.org>
* configure.ac: Add RTEMS_NETWORKING to cpuopts.h. Add RTEMS_DEPRECATED_TYPES to config.h. Add AC_CONFIG_COMMANDS(preinstall-stamp) magic. Misc. cleanups.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac28
1 files changed, 21 insertions, 7 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 5d4703bfde..152d7a6b93 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -63,6 +63,11 @@ AC_ARG_ENABLE([deprecated],
esac],[enable_deprecated=no])
AM_CONDITIONAL([DEPRECATED],[test "$enable_deprecated" = "yes"])
+AS_IF([ test "$enable_deprecated" = "yes" ],[
+AC_DEFINE_UNQUOTED([RTEMS_DEPRECATED_TYPES],[1],
+ [whether to support deprecated types])
+])
+
# HACK: We should use a feature-based configuration.
AS_IF([test x"${RTEMS_CPU}" = x"unix"],[
# HACK: silently accept --enable-unixlib
@@ -149,27 +154,32 @@ RTEMS_CPUOPT([RTEMS_ITRON_API],
[if itron api is supported])
RTEMS_CPUOPT([RTEMS_MULTIPROCESSING],
- [test x"$enable_multiprocessing" = x"yes"],
+ [test x"$enable_multiprocessing" = xyes],
[1],
[if multiprocessing is enabled])
RTEMS_CPUOPT([RTEMS_NEWLIB],
- [test x"$RTEMS_USE_NEWLIB" = x"yes"],
+ [test x"$RTEMS_USE_NEWLIB" = xyes],
[1],
[if using newlib])
RTEMS_CPUOPT([RTEMS_POSIX_API],
- [test x"$rtems_cv_HAS_POSIX_API" = x"yes"],
+ [test x"$rtems_cv_HAS_POSIX_API" = xyes],
[1],
[if posix api is supported])
+RTEMS_CPUOPT([RTEMS_NETWORKING],
+ [test x"$rtems_cv_HAS_NETWORKING" = xyes],
+ [1],
+ [if networking is enabled])
+
RTEMS_CPUOPT([RTEMS_UNIX],
- [test x"$RTEMS_CPU" = x"unix"],
+ [test x"$RTEMS_CPU" = xunix],
[1],
[to indicate RTEMS unix])
RTEMS_CPUOPT([RTEMS_UNIXLIB],
- [test x"${enable_unixlib}" = x"yes"],
+ [test x"${enable_unixlib}" = xyes],
[1],
[to indicate RTEMS using RTEMS's unixlib])
@@ -304,7 +314,11 @@ httpd/Makefile
ftpd/Makefile
telnetd/Makefile
pppd/Makefile
-wrapup/Makefile
-])
+wrapup/Makefile])
+
+AC_CONFIG_COMMANDS([preinstall-stamp],
+[test -z "$with_multisubdir" && ${MAKE} preinstall-stamp],
+[MAKE=${MAKE}
+with_multisubdir="$with_multisubdir"])
AC_OUTPUT