summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-29 18:51:49 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2010-06-29 18:51:49 +0000
commit263ab4bcb987f5ab607d0911200abe13b2c0ea5c (patch)
tree9b318360ba1da34b24a23b426cf7051803e084b1 /cpukit/configure.ac
parent2010-06-29 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-263ab4bcb987f5ab607d0911200abe13b2c0ea5c.tar.bz2
2010-06-29 Joel Sherrill <joel.sherrill@oarcorp.com>
* configure.ac, score/include/rtems/score/percpu.h: Add __RTEMS_SIZEOF_VOID_P__ to cpuopts.h so percpu.h has this information available during build and after installation.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index d74c424210..8ac8f5184c 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -118,6 +118,10 @@ rtems_major=`echo _RTEMS_VERSION | sed "s/\..*//"`
rtems_minor=`echo _RTEMS_VERSION | sed "s/[[0-9]][[0-9]]*\.//;s/\..*//"`
rtems_revision=`echo _RTEMS_VERSION | sed "s/[[0-9]][[0-9]]*\.//;s/[[0-9]][[0-9]]*\.//;s/\..*//"`
+## This is needed to generate the field offsets of the per CPU
+## data structure so they can be accessed from assembly code.
+AC_CHECK_SIZEOF([void *])
+
_RTEMS_CPUOPT_INIT
RTEMS_CPUOPT([RTEMS_DEBUG],
@@ -195,6 +199,14 @@ RTEMS_CPUOPT([__RTEMS_ADA__],
[1],
[Define to 1 if ada/gnat bindings are built-in])
+## Then we propagate a private copy of the value into cpuopts.h
+## so it is always available to the RTEMS header files.
+
+RTEMS_CPUOPT([__RTEMS_SIZEOF_VOID_P__],
+ [true],
+ [$ac_cv_sizeof_void_p],
+ [Size of a void * pointer])
+
RTEMS_CPUOPT([__RTEMS_MAJOR__],
[true],
[$rtems_major],
@@ -251,10 +263,6 @@ AC_CHECK_DECLS([sbrk],,,[#include <unistd.h>])
## Check if libc provides BSD's strlcpy/strlcat
AC_CHECK_FUNCS(strlcpy strlcat)
-## This is needed to generate the field offsets of the per CPU
-## data structure so they can be accessed from assembly code.
-AC_CHECK_SIZEOF([void *])
-
# ... far too many conditionals ...
AM_CONDITIONAL(LIBRPC,[test x"$rtems_cv_HAS_NETWORKING" = x"yes"])
AM_CONDITIONAL(NEWLIB,test x"$RTEMS_USE_NEWLIB" = x"yes")