summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-08-20 15:10:42 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-08-20 15:10:42 +0000
commit19b9991ecebf542ea78c307a876cb0c9defd0a64 (patch)
treefc3bb9e6c0b80cbd0f4206dc3c7aae6f1c8db63c /cpukit/configure.ac
parent2008-08-20 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-19b9991ecebf542ea78c307a876cb0c9defd0a64.tar.bz2
2008-08-20 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Abort if stdbool.h is not c99 compliant.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index cea851460e..9d5ae71c14 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -70,6 +70,8 @@ AS_IF([test x"${ac_cv_header_inttypes_h}" != xyes],
[AC_MSG_ERROR([Required header inttypes.h not found])])
AC_HEADER_STDBOOL
+AS_IF([test x"${ac_cv_header_stdbool_h}" != xyes],
+[AC_MSG_ERROR([No sufficient stdbool.h found])])
AC_CHECK_TYPES([ uint8_t, int8_t])
AC_CHECK_TYPES([uint16_t, int16_t])