summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-06-13 20:39:56 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-06-13 20:39:56 +0000
commit16aa296c973c14de8678339a3cc387ed9160b755 (patch)
tree1d48c46ac008ff6622c07dde438c241a2a80292a /cpukit/configure.ac
parent2007-06-13 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-16aa296c973c14de8678339a3cc387ed9160b755.tar.bz2
2007-06-13 Joel Sherrill <joel.sherrill@OARcorp.com>
* configure.ac: Add NDEBUG as a command line compilation option.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index f30804cd9c..6346996461 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -206,6 +206,12 @@ RTEMS_CPUOPT([SIZEOF_CPU_CONTEXT],
[$ac_cv_sizeof_CPU_CONTEXT],
[The size of a 'CPU_CONTEXT', as computed by sizeof])
+RTEMS_CPUOPT([NDEBUG],
+ [test x"${NDEBUG}" = x"1"],
+ [1],
+ [disable asserts]
+)
+
RTEMS_CPUOPT([__RTEMS_USE_TICKS_CPU_USAGE_STATISTICS__],
[test x"${USE_TICKS_FOR_CPU_USAGE_STATISTICS}" = x"1"],
[1],