summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2007-05-08 10:46:30 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2007-05-08 10:46:30 +0000
commit161016b55f41ece476946836b1ff0ebf6c5ac89f (patch)
tree9eb1c86971561bfd5f55dd1fbff4e2d08e75699a /cpukit/configure.ac
parent2007-05-08 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-161016b55f41ece476946836b1ff0ebf6c5ac89f.tar.bz2
2007-05-08 Ralf Corsépius <ralf.corsepius@rtems.org>
* configure.ac: Check for working PRIxPTR.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index f4452b2d5f..e743c2d537 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -75,6 +75,27 @@ AC_CHECK_TYPES([uint64_t, int64_t])
AC_CHECK_TYPES([uintmax_t, intmax_t])
AC_CHECK_TYPES([uintptr_t, intptr_t])
+AC_CACHE_CHECK([if PRIxPTR works],
+[rtems_cv_PRIxPTR],[
+ AS_IF([test x"$GCC" = xyes],[
+ save_CFLAGS=$CFLAGS
+ CFLAGS=-Werror])
+
+ AC_COMPILE_IFELSE([
+ AC_LANG_PROGRAM([
+ #include <inttypes.h>
+ #include <stdio.h>
+ ],[
+ void *ptr;
+ printf("%" PRIxPTR "\n", (intptr_t) ptr);
+ ])],
+ [rtems_cv_PRIxPTR=yes],
+ [rtems_cv_PRIxPTR=no])
+
+ AS_IF([test x"$GCC" = xyes],[
+ CFLAGS=$save_CFLAGS])
+])
+
# These are conditionally defined by the toolchain
# FIXME: we should either conditionally compile those parts in
# RTEMS depending on them, or abort - For now, simply check.