summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-10-02 21:33:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-10-02 21:33:09 +0000
commit0c34b176502eada476f0a9f9b3aeee346fbff9fd (patch)
tree3116b9ce721be5afccb4218d3bf2e7c91e0cd0bd /cpukit/configure.ac
parent2008-10-02 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-0c34b176502eada476f0a9f9b3aeee346fbff9fd.tar.bz2
2008-10-02 Joel Sherrill <joel.sherrill@oarcorp.com>
* configure.ac, score/cpu/Makefile.am: Initial addition of M32C port. This is still a work in process but most tests do run on simulator.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 9a60eca6f7..2a8e08719f 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -298,7 +298,15 @@ AM_CONDITIONAL(LIBNETWORKING,test x"$rtems_cv_HAS_NETWORKING" = x"yes")
AM_CONDITIONAL([NEED_SYS_CDEFS_H],[test x"$NEED_SYS_CDEFS_H" = x"yes"])
AM_CONDITIONAL([NEED_SYS_QUEUE_H],[test x"$NEED_SYS_QUEUE_H" = x"yes"])
-AM_CONDITIONAL([LIBSHELL],[test x"$HAVE_ASSIGNABLE_STDIO" = x"yes"])
+#case "${RTEMS_CPU}" in
+# m32c)
+# AM_CONDITIONAL([LIBSHELL],["no"])
+# ;;
+# *)
+ AM_CONDITIONAL([LIBSHELL],[test x"$HAVE_ASSIGNABLE_STDIO" = x"yes"])
+# ;;
+#esac
+
AM_CONDITIONAL([LIBSERDBG],[test x"$rtems_cv_cc_attribute_weak" = x"yes"])
AM_CONDITIONAL([LIBGNAT],[test x"$rtems_cv_HAS_POSIX_API" = x"yes" \
&& test x"$enable_ada" = x"yes"])
@@ -333,6 +341,7 @@ score/cpu/c4x/Makefile
score/cpu/h8300/Makefile
score/cpu/i386/Makefile
score/cpu/m68k/Makefile
+score/cpu/m32c/Makefile
score/cpu/mips/Makefile
score/cpu/nios2/Makefile
score/cpu/powerpc/Makefile