summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2014-09-15 08:50:28 +1000
committerChris Johns <chrisj@rtems.org>2014-09-16 15:19:58 +1000
commitebf9a057b5095df43632752d327e7c297b9fd78b (patch)
tree2b09f2946fd8a78eef7d1f76ba0df9db029cdae3 /cpukit/Makefile.am
parentshell: Add a ping command. (diff)
downloadrtems-ebf9a057b5095df43632752d327e7c297b9fd78b.tar.bz2
libmisc: Add a stdio redirector helper.
This module makes it easy to redirect and capture stdout, stderr or any other fd in your application. The captured data can be sent off board, for example using syslog, or buffered and displayed in a web page.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 2693d46f68..93b07c8a5d 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -175,6 +175,8 @@ include_rtems_HEADERS += libmisc/mouse/serial_mouse.h
## libqos
include_rtems_HEADERS += libqos/qreslib.h
+## redirector
+include_rtems_HEADERS += libmisc/redirector/stdio-redirect.h
## shell
if LIBSHELL
include_rtems_HEADERS += libmisc/shell/shell.h