summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2006-01-12 04:19:28 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2006-01-12 04:19:28 +0000
commitdbe8e5194cf71cb20e7a05ff382ad70e833fd3e6 (patch)
tree2c05c42afd7270e417e72e41a1e6e14d193d51c7 /cpukit/Makefile.am
parent2006-10-12 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-dbe8e5194cf71cb20e7a05ff382ad70e833fd3e6.tar.bz2
Cleanups
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 8b78fe0a23..691771be28 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -23,14 +23,11 @@ SUBDIRS += ftpd
SUBDIRS += telnetd
SUBDIRS += pppd
-CLEANFILES =
-DISTCLEANFILES =
-
noinst_DATA = preinstall-stamp
preinstall-stamp:
$(MAKE) $(AM_MAKEFLAGS) preinstall
touch preinstall-stamp
-CLEANFILES += preinstall-stamp
+CLEANFILES = preinstall-stamp
include_HEADERS =
@@ -171,7 +168,16 @@ include_rtems_HEADERS += libmisc/fsmount/fsmount.h
all-local: $(PREINSTALL_FILES)
-include $(srcdir)/preinstall.am
+cpukit.doxy: cpukit.doxy.in Makefile
+ d=`pwd`;cd $(PROJECT_INCLUDE);project_include=`pwd`;cd $$d; \
+ sed \
+ -e "s,[@]PROJECT_INCLUDE[@],$${project_include}," \
+ -e 's,[@]DOXY_FILTER[@],$(top_srcdir)/$(RTEMS_TOPdir)/tools/build/doxy-filter,' \
+ $(srcdir)/cpukit.doxy.in > cpukit.doxy
+
+doxy: preinstall-stamp cpukit.doxy
+ doxygen cpukit.doxy
+include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/subdirs.am
include $(top_srcdir)/automake/local.am