summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2019-06-25 21:07:40 +1000
committerChris Johns <chrisj@rtems.org>2019-07-31 08:33:05 +1000
commitcb1e8497dff1b26c11fff6881eaf4fb93c39f151 (patch)
treec69db9cfe6fc338c24b23a5e2d63e7690b515429 /cpukit/Makefile.am
parentarm: Select the TLB invalidate based on the core's Id variant. (diff)
downloadrtems-cb1e8497dff1b26c11fff6881eaf4fb93c39f151.tar.bz2
libdebugger: ARM fixes for Cortex-A8 and ARM mode.
- Fix destorying the target and thread parts. - Fix the ARM backend to support Cortex-A8 and ARM mode code. - Use the DBGDSCR interrupt mask when single stepping. - Use the DBGDSCR method of entry to debug mode to filter the execptions. - Add support for BSPs to control the ARM backend.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 8573f8fb64..3522916d8f 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -1882,6 +1882,7 @@ project_lib_LIBRARIES += libdebugger.a
libdebugger_a_SOURCES =
libdebugger_a_SOURCES += libdebugger/rtems-debugger-block.c
+libdebugger_a_SOURCES += libdebugger/rtems-debugger-bsp.c
libdebugger_a_SOURCES += libdebugger/rtems-debugger-cmd.c
libdebugger_a_SOURCES += libdebugger/rtems-debugger-remote.c
libdebugger_a_SOURCES += libdebugger/rtems-debugger-remote-tcp.c