summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2013-01-23 13:09:18 -0600
committerJoel Sherrill <joel.sherrill@oarcorp.com>2013-01-23 13:38:04 -0600
commitbb679b31119f59a0c27609f606967b4ba326dae4 (patch)
tree0399d7023685910e5b697ea6aa7fc40fbcf957ec /cpukit/Makefile.am
parentbsp/gen83xx: Disable caches in bsp_restart() (diff)
downloadrtems-bb679b31119f59a0c27609f606967b4ba326dae4.tar.bz2
Move <memory.h> and <sys/uio.h> to non-networking directory
These two header files were installed from libnetworking even when networking was disabled. This patch moves them to a non-networking location and updates uio.h to match the FreeBSD 8.x source being used for the USB stack and TCP/IP stack upgrade. - cpukit/include/memory.h Move from cpukit/libnetworking/memory.h. No changes - cpukit/include/sys/uio.h Move from cpukit/libnetworking/sys/uio.h. Replace with FreeBSD 8.x version. - cpukit/include/sys/_iovec.h New. FreeBSD 8.x file supporting <sys/uio.h>. - cpukit/Makefile.am Reflect movement of <memory.h> and <sys/uio.h>. - cpukit/preinstall.am Regenerate - cpukit/libnetworking/nfs/bootp_subr.c Eliminate use of uio_procp field no longer in FreeBSD structure. This field was set and never read so eliminating the set has no impact.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 5b11e7e6f6..fb8cd53f78 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -42,7 +42,7 @@ if NEWLIB
include_sysdir = $(includedir)/sys
include_sys_HEADERS =
-include_HEADERS += libnetworking/memory.h
+include_HEADERS += include/memory.h
include_HEADERS += libmd/md4.h
include_HEADERS += libmd/md5.h
@@ -55,7 +55,8 @@ include_sys_HEADERS += libcsupport/include/sys/ttycom.h
include_sys_HEADERS += libcsupport/include/sys/termios.h
include_sys_HEADERS += libcsupport/include/sys/utsname.h
-include_sys_HEADERS += libnetworking/sys/uio.h
+include_sys_HEADERS += include/sys/uio.h
+include_sys_HEADERS += include/sys/_iovec.h
include_sys_HEADERS += include/sys/priority.h
if LIBNETWORKING