summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-08-30 15:01:38 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2019-10-01 09:55:07 +0200
commita314544a278f1533ae001f742d7fe24fcee253e6 (patch)
tree64b5cec3ddc5111df8f229fdbd57376d66195043 /cpukit/Makefile.am
parentMAINTAINERS: Remove Martin Galvan (diff)
downloadrtems-a314544a278f1533ae001f742d7fe24fcee253e6.tar.bz2
record: Add wrappers for malloc() functions
Introduce new library librtemsrecordwrap.a which contains wrappers for operating system functions which produce entry/exit events. The wrappers can be selected during link time via the GNU ld --wrap option. Update #3665.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 01ee40980f..3914b3d363 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -1831,6 +1831,11 @@ project_lib_LIBRARIES += librtemsdefaultconfig.a
librtemsdefaultconfig_a_SOURCES =
librtemsdefaultconfig_a_SOURCES += libmisc/dummy/default-configuration.c
+project_lib_LIBRARIES += librtemsrecordwrap.a
+
+librtemsrecordwrap_a_SOURCES =
+librtemsrecordwrap_a_SOURCES += libtrace/record/record-wrap-malloc.c
+
project_lib_LIBRARIES += librtemstest.a
librtemstest_a_SOURCES =