summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2016-11-25 15:13:36 +1100
committerChris Johns <chrisj@rtems.org>2016-11-29 08:50:40 +1100
commita0d4e9933c57693f99203da358bb8aaa8a5d50d9 (patch)
treed17a98faf93185d2baa18fba6ee97b0e2916b2e4 /cpukit/Makefile.am
parentarm/zynq: Wait for the UART TX FIFO to empty on reset. (diff)
downloadrtems-a0d4e9933c57693f99203da358bb8aaa8a5d50d9.tar.bz2
cpukit: Add libdebugger, a remote debugger agent for GDB.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 6ca5e1652e..73bf35d8ba 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -18,6 +18,7 @@ SUBDIRS += libmd
SUBDIRS += libgnat
SUBDIRS += libdl
SUBDIRS += libstdthreads
+SUBDIRS += libdebugger
SUBDIRS += wrapup
SUBDIRS += zlib
@@ -99,6 +100,14 @@ include_rtems_rtl_HEADERS += libdl/rtl-indirect-ptr.h libdl/rtl-sym.h libdl/rtl-
include_rtems_rtl_HEADERS += libdl/rap.h libdl/rap-shell.h
endif
+if LIBDEBUGGER
+include_rtems_HEADERS += libdebugger/rtems-debugger.h
+include_rtems_debuggerdir = $(includedir)/rtems/debugger
+include_rtems_debugger_HEADERS =
+include_rtems_debugger_HEADERS += libdebugger/rtems-debugger-server.h
+include_rtems_debugger_HEADERS += libdebugger/rtems-debugger-remote.h
+endif
+
include_rtems_HEADERS += include/rtems/bspIo.h
include_rtems_HEADERS += include/rtems/print.h
include_rtems_HEADERS += include/rtems/printer.h