summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2020-03-03 13:45:50 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-03-04 08:43:45 +0100
commit8b73ee50238d5f22db792bf8cc573a001f52065f (patch)
treec2522f35266d86ca51c74daae66bab4f09c7bae0 /cpukit/Makefile.am
parentconfig: Remove <rtems/btimer.h> include (diff)
downloadrtems-8b73ee50238d5f22db792bf8cc573a001f52065f.tar.bz2
rtems: rtems_scheduler_get_processor_maximum()
In uniprocessor configurations, use compile-time constants for rtems_scheduler_get_processor_maximum() and rtems_scheduler_get_processor(). This helps compilers and static analyzers to deduce that some loop bodies are only executed once and some conditional statements have a fixed outcome (may improve code generation and reduce false positives). In SMP configurations, directly provide the internal implementation for performance reasons.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 298580e20d..783a9bbf42 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -700,8 +700,6 @@ librtemscpu_a_SOURCES += rtems/src/eventseize.c
librtemscpu_a_SOURCES += rtems/src/eventsend.c
librtemscpu_a_SOURCES += rtems/src/eventsurrender.c
librtemscpu_a_SOURCES += rtems/src/getapiconfig.c
-librtemscpu_a_SOURCES += rtems/src/getcurrentprocessor.c
-librtemscpu_a_SOURCES += rtems/src/getprocessorcount.c
librtemscpu_a_SOURCES += rtems/src/intrbody.c
librtemscpu_a_SOURCES += rtems/src/intrcatch.c
librtemscpu_a_SOURCES += rtems/src/modes.c