summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-03-25 08:09:09 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2019-03-25 08:09:36 +0100
commit7a1934dac087295b209563d984549a48728599a3 (patch)
treede02f97c4e486a43461a1cf7755d09898f11efae /cpukit/Makefile.am
parentscore: Update Objects_Information documentation (diff)
downloadrtems-7a1934dac087295b209563d984549a48728599a3.tar.bz2
build: Always build libmghttpd.a
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am14
1 files changed, 5 insertions, 9 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 51ab18ca05..b0b5a8d286 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -1902,6 +1902,11 @@ libjffs2_a_CPPFLAGS =
libjffs2_a_CPPFLAGS += $(AM_CPPFLAGS)
libjffs2_a_CPPFLAGS += -I$(srcdir)/libfs/src/jffs2/include
+project_lib_LIBRARIES += libmghttpd.a
+
+libmghttpd_a_SOURCES =
+libmghttpd_a_SOURCES += mghttpd/mongoose.c
+
project_lib_LIBRARIES += libz.a
libz_a_SOURCES =
@@ -1953,15 +1958,6 @@ libpppd_a_SOURCES += pppd/sys-rtems.c
libpppd_a_SOURCES += pppd/upap.c
libpppd_a_SOURCES += pppd/utils.c
-if HAS_PTHREADS
-
-project_lib_LIBRARIES += libmghttpd.a
-
-libmghttpd_a_SOURCES =
-libmghttpd_a_SOURCES += mghttpd/mongoose.c
-
-endif
-
endif
if HACK_TO_AVOID_LONG_ARG_LIST