summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-01-14 09:08:18 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2019-03-26 11:29:58 +0100
commit6fe01e4b3d52b47c916bc4989e042255ff38e2ca (patch)
tree42b8d48366aeccc1bf26aa96311191947b13bcf3 /cpukit/Makefile.am
parentscore: Add ARM CPU architecture group (diff)
downloadrtems-6fe01e4b3d52b47c916bc4989e042255ff38e2ca.tar.bz2
build: Move test support to librtemstest.a
One reason to move the test support into a dedicated library are the standard output __wrap_*() functions. They may conflict with application level wrappers. Update #3199.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index b0b5a8d286..9e77facccb 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -322,11 +322,6 @@ librtemscpu_a_SOURCES += libmisc/stringto/stringtounsignedchar.c
librtemscpu_a_SOURCES += libmisc/stringto/stringtounsignedint.c
librtemscpu_a_SOURCES += libmisc/stringto/stringtounsignedlong.c
librtemscpu_a_SOURCES += libmisc/stringto/stringtounsignedlonglong.c
-librtemscpu_a_SOURCES += libmisc/testsupport/testbeginend.c
-librtemscpu_a_SOURCES += libmisc/testsupport/testbusy.c
-librtemscpu_a_SOURCES += libmisc/testsupport/testextension.c
-librtemscpu_a_SOURCES += libmisc/testsupport/testparallel.c
-librtemscpu_a_SOURCES += libmisc/testsupport/testwrappers.c
librtemscpu_a_SOURCES += libmisc/untar/untar.c
librtemscpu_a_SOURCES += libmisc/untar/untar_tgz.c
librtemscpu_a_SOURCES += libmisc/untar/untar_txz.c
@@ -1834,6 +1829,15 @@ project_lib_LIBRARIES += librtemsdefaultconfig.a
librtemsdefaultconfig_a_SOURCES =
librtemsdefaultconfig_a_SOURCES += libmisc/dummy/default-configuration.c
+project_lib_LIBRARIES += librtemstest.a
+
+librtemstest_a_SOURCES =
+librtemstest_a_SOURCES += libtest/testbeginend.c
+librtemstest_a_SOURCES += libtest/testbusy.c
+librtemstest_a_SOURCES += libtest/testextension.c
+librtemstest_a_SOURCES += libtest/testparallel.c
+librtemstest_a_SOURCES += libtest/testwrappers.c
+
project_lib_LIBRARIES += libftpd.a
libftpd_a_SOURCES =