summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2017-08-16 14:22:23 +1000
committerChris Johns <chrisj@rtems.org>2017-08-20 11:11:46 +1000
commit6b7efdb2ed77760e3c68c5cf450a9620a1cd6562 (patch)
tree7af6121eedd638496f7dc8c2ad380e9917692f14 /cpukit/Makefile.am
parentdev/i2c: Add I2C device support for FPGA Slave, LM25066A, TMP112, ADS1113, AD... (diff)
downloadrtems-6b7efdb2ed77760e3c68c5cf450a9620a1cd6562.tar.bz2
libmisc/rtems-fdt: Add RTEMS FDT wrapper and shell command to libmisc.
- Provide application support for handling FDT blobs in RTEMS. This is useful when interfacing FPGA fabrics. - Provide a shell command to list a blob as well as provide read and write access to addresses in the FTB. Closes #3099.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 2c2f2e5cfb..8ccc1d4e9a 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -218,6 +218,10 @@ include_rtems_HEADERS += libmisc/devnull/devzero.h
## dumpbuf
include_rtems_HEADERS += libmisc/dumpbuf/dumpbuf.h
+## rtemsfdt
+include_rtems_HEADERS += libmisc/rtems-fdt/rtems-fdt.h
+include_rtems_HEADERS += libmisc/rtems-fdt/rtems-fdt-shell.h
+
## monitor
include_rtems_HEADERS += libmisc/monitor/monitor.h