summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-27 06:23:29 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2017-11-27 09:36:56 +0100
commit642ef003ec0b62ede17acf5d2c4af2d2a3d35f66 (patch)
treecdf87e06a031af29ebe018cbc8b4b8442cd783aa /cpukit/Makefile.am
parentMove Ada includes (diff)
downloadrtems-642ef003ec0b62ede17acf5d2c4af2d2a3d35f66.tar.bz2
bsps: Provide <tm27.h> in each BSP
Since the <tm27.h> is highly BSP-dependent and used only by the tm27 test program we must provide this header file for each BSP. Without the preinstall build target each header file must have a unique source header file. Update #3254.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index d905f2b73a..f6ee1bfbed 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -270,6 +270,8 @@ include_rtems_HEADERS += libmisc/untar/untar.h
## fsmount
include_rtems_HEADERS += libmisc/fsmount/fsmount.h
+include_rtems_HEADERS += include/rtems/tm27-default.h
+
## Driver manager
if LIBDRVMGR
include_drvmgrdir = $(includedir)/drvmgr