summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2020-04-09 15:41:38 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-08-31 17:30:17 +0200
commit2d5510307af3222572238f139bd355952614f482 (patch)
tree1d5a3bfa0d0bfb9185f3f897e140a6ee1c76f485 /cpukit/Makefile.am
parentscore: Add _Stack_Allocator_do_initialize() (diff)
downloadrtems-2d5510307af3222572238f139bd355952614f482.tar.bz2
score: Move _Stack_Allocator_free to separate file
This decouples the task stack allocation from the deallocation. Update #3959.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 4ba3fd48d1..a8cc9b2b1d 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -932,6 +932,7 @@ librtemscpu_a_SOURCES += score/src/schedulercbssetparameters.c
librtemscpu_a_SOURCES += score/src/schedulercbsreleasejob.c
librtemscpu_a_SOURCES += score/src/schedulercbsunblock.c
librtemscpu_a_SOURCES += score/src/stackallocator.c
+librtemscpu_a_SOURCES += score/src/stackallocatorfree.c
librtemscpu_a_SOURCES += score/src/stackallocatorinit.c
librtemscpu_a_SOURCES += score/src/pheapallocate.c
librtemscpu_a_SOURCES += score/src/pheapextend.c